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LDAP stands for Lightweight Directory Access Protocol , which is a client -server protocol 

for accessing a directory service. LDAP is a directory service protocol that runs over 

TCP/IP. The nitty -gritty details of LDAP are defined in RFC 1777 "Lightweight Directory 

Access Protocol" . 

The following gives an overview of LDAP from a user's perspective.  

What kind of information can be stored in  the directory?  

The LDAP information model is based on entries. An entry is a collection of attributes 

that has a globally -unique Distinguished Name (DN). The DN is used to refer to the entry 

unambiguously. Each of the entry's attributes has a type and one  or more values. The 

types are typically mnemonic strings, like "cn" for common name, or "mail" for email 

address. The syntax of values depend s on the attribute type. For example, a cn 

attribute might contain the value òBabs Jensen ó. A mail attribute might  contai n the 

value "babs@example.com".  

How is the information arranged?  

In LDAP, directory entries are arranged in a hierarchical tree -like structure. Traditionally, 

this structure reflected the geographic and/or organizational boundaries. Entries 

represen ting countries appear at the top of the tree. Below them are entries 

representing states and national organizations. Below them might be entries 

representing organizational units, people, printers, documents, or just about anything 

else you can think of. The following  shows an example of LDAP directory tree using 

traditional naming.  
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LDAP enable s you  to locate organizations, individuals, and other resources such as files 

and devices in a network, whether on the Internet or on a corporate intranet , and 

whether or not you know the domain name, IP address, or geographic whereabouts. An 

LDAP directory can be distributed among many servers on a network, then replicated 

and synchronized regularly.  LDAP is particularly useful for storing information that y ou 

wish to read from many locations, but update infrequently.  

This guide  provides configurations on the LDAP server and IP phone s, and appl ies to 

Yeali nk SIP-T28P, SIP-T26P, SIP-T22P, SIP-T21P, SIP-T46G, SIP-T42G and  SIP-T41P IP phones 

runnin g firmware version 7 2 or later . 
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An LDAP server is essentially a bit like an SQL server , which is mainly used for 

stor ing /retriev ing  information about people  (such as contacts). The configuration 

settings on the phone will be altered depending on how the LDAP server is configured.  

Before using  LDAP feature on IP phones, you must make sure the  LDAP server is 

prepared pr operly, otherwise you need to install and configure an LDAP server. This 

chapter shows  you how to install and configure an LDAP server. We recommend you to 

use the OpenLDAP or Microsoft Active Directory on Windows system.  

This section shows you how to install an OpenLDAP server  on Microsoft Windows XP 

system . The OpenLDAP server software  is available for  free . You can download it from 

http://www.openldap.org/software/download/ . 

To install the OpenLDAP server : 

1. Double click the OpenLDAP application  to start the  installation.  Follow the default 

settings and click Next . 

2. Click  Browse  to locate the installation path from local computer system  and  then 

click Next . 

You need to remember the installation path  (e.g.,  C:\OpenLDAP ) located here.  

The screenshot for reference is shown as below:  
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3. Select Full installation , the screenshot for reference is shown as below:  

 

4. Follow the default settings and click Next . 

5. Click Finish to finish the installation.  

Access the slapd.conf file at  the OpenLDAP installation path . Open and edit the 

slapd.conf file using  your favorite  text editor . 

1. Add the schema commands.  

Find the command  include   ./schema/core.schema  and add the following 

commands below it . 

These two commands must be added : 

include   ./schema/cosine.schema  

include   ./schema/inetorgperson.schema  

These commands  can be added  optionally:  

include   ./schema/ corba.schema  

include   ./schema/dyngroup.schema  

include   ./schema/java.schema  

include   ./schema/misc.schema  

include   ./schema/nis.schema  

include   ./schema/openldap.schema  

2. Edit the manager information  for LDAP phonebook . 

Find the command s  

Suffix   "dc=my -domain, dc=com"  

Rootdn   "cn= manager,dc=my -domain, dc=com"  

Rootpw   secret  
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Suffix  defines  the components of the  domain name.  

Rootdn defines the manager as a management user for access ing  the LDAP server.  

Rootpw defines the user password for  the  management  user. 

For example : 

Suffix   "dc=yealink,dc=cn"  

Rootdn   "cn=manager,dc=yealink,dc=cn"  

Rootpw   secret  

The suffix line means that the domain name of the LDAP phonebook is yealink.cn. 

The Rootdn line defines a management user named as  manager. The Rootpw line 

defines the password òsecret ó for the management user.  

If the domain name contains additional components, for example,  yealink.com.cn, 

the suffix line  will be edited  as below : 

Suffix   "dc=yealink, dc=com, dc=cn"  

Rootdn   "cn=manager,dc=yealink, dc= com, dc=cn"  

Rootpw   secret  

To start the slapd  serv ice : 

1. Click Start -> Run. 

2. Enter cmd  in the pop -up dialogue box and click  OK to enter the  command line  

interface.  

3. Execute  the cd  command to locate the server installation path. For example, 

execute  cd c: \OpenLDAP  to locate the server installation path at c:\OpenLDAP . 

 

4. Execute  the command  slapd  ðd 1  to start the slapd serv ice . 
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If the serv ice  runs successfully, you can find the prompt òslapd starting ó. 

The screenshot for reference  is shown as below:  

 

Please do not close this window to make sure the LDAP server keep s running.  

You can add the initial entr y to the  LDAP directory  by using the  LDIF file . Create a new 

text document , then modify the filename extension as ldif  and  place the document to 

the  OpenLDAP installation path . For example, create a text document named as test.txt, 

right click the test.txt document  and then select to rename it, modify the filename 

extension as ldif. Open the LDIF file with your fav orite text editor and input the  

corresponding  content . The following shows an example of the content of the LDIF file:  

dn: dc=yealink,dc=cn  

objectclass: d cobject  

objectclass: organization  

o: xmyealink  

dc: yealink  

 

dn: cn=manager,dc=yealink,dc=cn  

dc=yealink  

objectclass: dcobject  

objectclass: organization  

cn=manager  

sn: sumer  

To add the initial entry using the test .ldif file:  

1. Click Start -> Run. 

2. Execute  cmd  in the pop -up dialogue box  and click  OK to enter  the  command line 

interface . 
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3. Execute  the command cd c: \OpenLDAP  to access  the OpenLDAP installation path at 

c:\OpenLDAP . 

4. Execute  the command ldapadd -x -D "cn=manager,dc= yealink,dc=cn" -w secret -f 

test.ldif  to add the initial entry . 

The screenshot for reference is shown as below:  

 

The LDAPExploreTool2 application supports run ning  on Windows system. The 

application is a  graphical LDAP tool that enables you to browse , modify and manage  

contact entry on  LDAP server. 

If you have a n LDAPExploreTool2 application  installed on your computer, open it now , 

otherwise, download the application from http://ldaptool.sourceforge.net/ . And then 

complete the installation following the wizard . 

To create a configuration:  

1. Double click the LDAPExploreTool2 .exe to run the application.  

2. Click File-> Configurations . 

 

3. Click New  to c reate a new configuration . 
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4. Enter a name in the Configuration name field  under the Configuration  tab . 

 

5. Enter the domain name or IP address of the LDAP server in the Server name or IP  

field under the Server  tab . Check the checkbox of  Use default port  for the Server 

port  and Server SSL port . 

 

6. Enter the user DN and password in the User DN  and  Password  field under the 

Connection  tab.  

The user DN and password correspond with the Rootdn and Rootpw defined in the 

slapd.conf file.  
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For example, according to the manager information defined in the slapd.conf file:  

Rootdn   "cn=manager,dc= yealink,dc=cn"  

Rootpw   secret  

Enter cn=manager,dc=yealink,dc=cn  in the User DN  field and secret  in the 

Password  field under the Connection  tab . 

 

7. Click Guess value  to fill the Base DN  automatically . 

8. Click Test connection  to test the connection to the LDAP server. If you encounter an 

error or warning during the test, you need to resolve the error or warning first 

according to the prompt, and then retry to test the connection.  

9. Click OK to accept the change.  

To add entries : 

1. Click File-> Configurations , select the configuration created above , and then click 

Open .  

The screenshot for reference is shown as below:  
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2. Right click the root entry , and then select Add to add a new  entr y. 

 

3. Enter the desired values in the corresponding fields.  

Parent DN:  It will be automatic ally generat ed according to the server configuration . 

Entry RDN: The format is cn=XXX . This is a unique identifier for each entry . 

Object Class  (from schema):  Select the structure class which the entry belongs to . 

Each structure class has its own must attributes  and may attributes. For example , 

we select person  from the pull -down list of Object class  (from schema) . 

4. Select the desired attributes for object class.  

Must attributes:  Double click attrib utes to add them to the entry node.  All attributes 

listed in the Must attributes  field must be added and each value of the attribute 

must be set.  

May attributes:  Double click the desired attribute s to add them to the entry node.  

The attributes listed in the M ay attributes  field  are  optional . 

Common attributes are listed in the following table :  

Attribute  Name  Description  

cn commonName  Full name of the entry.  

gn  givenName  
First name also called Christian 

name.  

sn surname  
Surname,  last name or family 

name.  

telephoneNumber  telephoneNumber  Office phone number.  

homePhone  homeTelephoneNumber  Home phone number.  

mobile  mobileTelephoneNumber  
Mobile or cellular phone 

number.  

pager  pagerTelephoneNumber  Pager telephone number.  

company  company  Company name.  

o organizationName  Organization name.  
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Attribute  Name  Description  

ou organizationlUnitName  
Usual department or any sub 

entity of larger entity.  

5. Right click the selected attribute and then select Add value . 

The screenshot of adding a  new  entry is shown as below:  

 

6. Click Save  to confirm the configuration.  

7. Repeat steps 2 to 6 to add more contact entries.  

You can find the added entr ies at the left of the LDAP catalogue.  

 

The value of cn here m ust be the 

same as that  of cn  configured in the 

Entry RDN field.  
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This section shows you how to install a n active directory on M icrosoft Windows Server 

2008 R2 Enterprise 64 -bit  system . 

To install th e Microsoft Active Directory Domain S erv ices: 

1. Click Start -> Run. 

2. Enter dcpromo  in the pop -up dialogue box and click  OK. 

3. The Active Directory Domain Services Installation Wizard  will appear after a short 

while, click Next . 
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4. Read the provided information and click Next . 

 

5. Mark the  Create a new domain in a new forest  radio box and  click Next . 
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6. Enter an appropriate domain name for the forest root domain  and  click Next . 

 

The wizard will check if the domain name is  in use on  the local network.  

 

7. Select the desired forest function al  level  from the pull -down list of Forest  function al  

leve l, and  click Next . 

  



   Installing and Configuring the LDAP Server  

15 

For more information , click domain and forest functional level s. 

 

8. Select the desired domain  function al  level from the pull -down list of Domain 

function al  leve l, and  click Next . 

For more information, click domain and forest functional level s. 

 

  If you select Windows Server 2008  R2 for the forest function al  level, you will not  be 

prompted to select  a domain function al  level.  
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The wizard will check if the DNS is properly configured on the local network.  

 

9. Select additional options for this domain controller if required, and c lick Next . 

 

 

  

You may get a warning telling you that the server has one or more dynamic IP 

addresses. We recommend  assigning a static IP address to the server . 
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10. The wizard will prompt a warning about DNS delegation. Since no DNS has been 

configured yet, you can ignore the message and click Yes. 

 

11. Specify the desired paths for the database, log files and SYSVOL folders , and click 

Next . 

For more information , click placing Active Directory Domain Services files . 
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12. Configure the password for the active directory recovery mode, and click Next . 

For more information , click Directory Services Restore Mode password . 

The password should be complex  and at least 7 characters long.  

 

13. Review your selection and click Next . 
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The wizard will prompt that the system begin s to creat e the Active Directory Domain  

Services . 

 

14. Click Finish to complete and exit the wizard.  

 

You should also install the Active Directory Lightweight Directory Services role  on 

Windows Server 2008  system . 

To install the Active Directory Lightweight Directory Services role : 

1. Click  Start -> Administrative Tools -> Server Manager . 
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2. Right click Roles, and then select Add Roles . 

3. The Add Roles Wizard wi ll pop up , click Next . 

 

4. Check the Active Directory Lightweight Directory Services  checkbox and click Next . 

 

5. Follow the default settings and click Next . 

6. When the installation  is completed , click Close . 
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After the installation succeeds , you will find the Active Directory Lightweight 

Directory Services  role  listed in  roles of the server manager . 

 

You can add entries to the active directory one by one in this way.  

To add a n entry  to the Active Directory : 

1. Click  Start -> Administrative Tools -> Server Manager . 

2. Double click  Roles-> Active Directory Domain Services -> Active Directory Users and  

Computers . 

3. Right click the domain name  created above (e.g., ldap.ye alink.com ), and then 

select  New -> Organizational Unit . 
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4. Enter the desired name of the organizational unit . 

 

5. Click OK to accept the change.  

6. Right click the organizational unit  created above , and then select  New -> Contact . 
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7. Enter the desired value s in the corresponding  fields.  

 

8. Click OK to accept the change.  

9. Double click the contact  created above . 

10. Configure more  propert ies of the contact.  

 

11. Click OK to accept the change.  
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You can use a LDIF file to perform  a batch import of all entries  to the active directory.  

Create a new text document  and then modify the filename extension as ldif. For 

example, create a text document  named as test .txt, right click the test .txt document  and 

then select to rename it, modify the filename extension as ldif. Open the LDIF file with 

your fav orite text editor and input the corresponding  content . The following shows an 

example of the content of the LDIF file:  

 

To import  the  test .ldif file:  

1. Click Start -> Run. 

2. Enter cmd  in the pop -up dialogue box and click OK to enter the  command line 

interface.  

  

##Create a new organizational unit##  

dn: OU=yealink,DC= ldap,DC=yealink,DC=com  

changetype: add  

objectClass: top  

objectClass: organizationalUnit  

ou: yealink  

name: yealink  

 

##create a new contact##  

dn: CN=san zhang,OU=yealink,DC=ldap,DC=yealink,DC=com  

changetype: add  

objectClass: top  

objectClass: person  

objectClass: organizationalPerson  

objectClass: contact  

cn: san zhang  

sn: zhang  

givenName: san  

initials: zs  

name: san zhang  

ipPhone: 2336  

mobile: 15557107369  
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3. Execute the command cd to access  the path of the test .ldif file . For example, 

execute  cd c: \Windows  to access  the path of the test .ldif file  at c:\Windows . 

 

4. Execute  the command  ldifde  -i  -f  test .ldif  to import the file.  

If the entries are add ed  successfully, you can find the prompt òn entries modified 

successfully ó ("n" indicates the numbe r of the added entries ). 

The screenshot for reference is shown as below:  

 

 

 

You can also export the existing entries on the active directory into a *.ldif file first, 

modify the file, and then import the modified file into the active directory. For more 

information, refer to the network resource.  
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You can also use a CSV file to perform a batch import of all entries to the active directory.  

Create a new  document  using a spreadsheet application  (e.g ., Microsoft Excel)  and 

then save  the document to your local computer using òSave as ó in the format ò*.csv ó. 

For example, create a document  named as test .xls, click òSave as ó to save the 

document as test.csv . Open the CSV file with the spreadsheet application  and input the 

corresponding  content . The following shows an example of the CSV file  content : 

 

 

To import  the  test .csv file:  

1. Click Start -> Run. 

2. Enter cmd  in the pop -up dialogue box and click OK to enter the  command line 

interface.  

3. Execute  the command cd to access  the path of the test .csv file . For example, 

execute  cd c: \Windows  to access  the path of the test .csv file  at c:\Windows . 

 

4. Execute  the command  csvde   -i  -f  test.csv to import the file.  

  

The first line lists the attributes of the entries.  

The second line lists the values of an organizational unit  in the corresponding attribute 

columns.  

The other lines list the values of contacts in the corresponding attribute columns.  
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If the entries are added  successfully, you can find the prompt òn entries modified 

successfully ó ("n" indicates the numbe r of the added entries ). 

The screenshot for reference is  shown as below:  

 

 

You can create user accounts to allow access to resources on the active directory . User 

accounts  are very  important and useful.  

To create a  user account : 

1. Click  Start -> Administrative Tools -> Server Manager . 

2. Double click  Server Manager -> Roles-> Active Directory Domain Services -> Active 

Directory Users and  Computers . 

3. Select the domain name created above (e.g.,  ldap. yealink. com). 

4. Right click Users, and then select  New -> User. 

 

  

The csvde  tool cannot edit or delete the existing e ntries on the active directory.  

You can also export the existing entries on the active directory into a *.csv file first, 

modify the file, and then import the modified file into the active directory. For more 

information, refer to the network resource.  
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5. Enter desired values in the corresponding  fields and click Next . 

 

6. Enter the password  for the user , select the appropriate options  and click Next . 

The password should be  a combination  of upper case letters, lower case letters, 

numbers  and  special  characters . 
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7. Click Finish to complete the creation of the user account . 
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LDAP is disabled  on IP phone s by default. You can configure LDAP via  web user 

interface  or using configuration files . The followings take configurations of a SIP -T28P IP 

phone running firmware version 7 2 as examples.  

To configure  LDAP feature via web user interface:  

1. Press the OK key o n the phone when it is idle to obtain the IP address.  

2. Enter the IP address (e.g. , http://192.168.0.10 or 192.168.0.10) in the address bar of 

web browser on your PC  and then press  Enter. 

3. Enter the user name  and password  in the login page . 

The default login user name is admin (case -sensitive) and the password is admin 

(case -sensitive).  

4. Click on Directory -> LDAP. 

5. Select Enabled  from the pull -down list of Enable  LDAP. 

6. Enter the desired values in the corresponding fields.  

The screenshot for reference is show n as below : 

 

7. Click Confirm  to accept the change.  

  


